Delays on asset updates in Iris

Incident Report for Trackunit

Resolved

Issue fixed and systems recovering
Posted Oct 24, 2025 - 14:39 CEST

Identified

We have identified the error and are working on a fix. Updates are being processed and kin onboarding is available again.
Posted Oct 24, 2025 - 13:16 CEST

Investigating

We are currently investigating and issue where we see delays in asses and kin onboarding from Iris.
Posted Oct 24, 2025 - 12:51 CEST
This incident affected: Trackunit Manager.