Potential data delays between Manager Classic and New Manager
Incident Report for Trackunit
Resolved
This incident has been resolved.
Posted Nov 17, 2020 - 11:26 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2020 - 10:33 CET
This incident affected: Trackunit Manager, Trackunit Go, and Trackunit On.