Data delay in Trackunit Manager Classic

Incident Report for Trackunit

Resolved

This incident has been resolved.
Posted Mar 29, 2026 - 18:47 CEST

Identified

We have identified the issue, we continue to monitor it.
Posted Mar 29, 2026 - 12:45 CEST

Investigating

We are experiencing data delays in Classic due to a database infrastructure issue.
Posted Mar 29, 2026 - 12:34 CEST
This incident affected: Manager Classic.