Scheduled system maintenance on Trackunit Iris platform

Scheduled for Mar 2, 20:00 - 21:00 CET

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 25, 2026 - 14:07 CET

Scheduled

We are performing a scheduled system maintenance on the Trackunit Iris infrastructure to keep it highly available and secure.

Affected services may experience slightly degraded performance.
Posted Feb 25, 2026 - 20:00 CET
This scheduled maintenance affects: Streaming API.