Data delays for TU40x / 50x / 60x units
Incident Report for Trackunit
Resolved
The incident has been resolved.
Posted Feb 16, 2024 - 12:31 CET
Investigating
Due to an IRIS infrastructure issue, some customers can experience data delays in Trackunit Manager Classic, Go, and On.
Posted Feb 16, 2024 - 12:10 CET
This incident affected: Trackunit Go, Trackunit On, and Manager Classic.