Degraded Platform Performance

Incident Report for Trackunit

Resolved

This incident has been resolved.
Posted Jan 29, 2026 - 15:08 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 29, 2026 - 14:12 CET

Investigating

We are currently experiencing degraded performance across parts of the Trackunit platform. This may affect Manager, Verify, and some API endpoints.

Our team is actively investigating the issue. We will provide another update as soon as we have more information.
Posted Jan 29, 2026 - 13:37 CET
This incident affected: Trackunit Manager, Trackunit Go, Trackunit API, and Trackunit Verify.