Degraded performance in Manager and Verify

Incident Report for Trackunit

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 12:32 CEST

Investigating

We are currently experiencing degraded performance in Manager and Verify. We are investigating and will provide an update as soon as more information becomes available.
Posted Apr 23, 2026 - 12:18 CEST
This incident affected: Trackunit Manager and Trackunit Verify.