Specifications can't be edited

Incident Report for Trackunit

Resolved

This incident has been resolved. Please logout and log back in again.
Posted Mar 05, 2026 - 15:54 CET

Investigating

We are currently investigating the issue.
Posted Mar 05, 2026 - 15:31 CET
This incident affected: Trackunit Manager and Trackunit Verify.