The infrastructure issue has been resolved, and Trackunit services should now be operating normally.
Posted Jul 23, 2026 - 08:15 CEST
Update
The fixes previously implemented are working as expected. Since our systems are working through a large backlog of data we still see delays in data ingestion. We will monitor through the night and update the status page tomorrow morning CEST.
Posted Jul 23, 2026 - 00:07 CEST
Update
We are seeing improvements, still monitoring the situation.
Posted Jul 22, 2026 - 22:01 CEST
Update
The updates are progressing. In 30 minutes, we should have new updates.
Posted Jul 22, 2026 - 20:51 CEST
Update
We are continuing to monitor the situation.
Posted Jul 22, 2026 - 18:21 CEST
Monitoring
We are monitoring a fix and making small adjustments.
Posted Jul 22, 2026 - 16:42 CEST
Identified
We have identified another issue in the pipeline and we are working on a fix.
Posted Jul 22, 2026 - 15:38 CEST
Update
We are below 30 minutes of delays in the pipelines. We hope to be fully up-to-date within 15 minutes.
Posted Jul 22, 2026 - 14:44 CEST
Update
We are still seeing several hours of delays for updating telematics data in Manager, apps and APIs. Streaming APIs are almost up-to-date.
Posted Jul 22, 2026 - 13:08 CEST
Update
We are continuing to monitor for any further issues.
Posted Jul 22, 2026 - 13:01 CEST
Monitoring
A fix has been implemented and we are monitoring the results. Delay is around 1 hour 30 minutes.
Posted Jul 22, 2026 - 11:26 CEST
Identified
The issue has been identified. Work is in progress to fix the issue.
Posted Jul 22, 2026 - 09:58 CEST
Update
We are continuing to investigate this issue. Delay is around 1 hour 10 minutes.
Posted Jul 22, 2026 - 09:36 CEST
Update
We are continuing to investigate this issue.
Posted Jul 22, 2026 - 09:08 CEST
Investigating
Due to an Trackunit infrastructure issue, some customers can experience data delays in Trackunit Manager, APIs, Go, and On. Delay is around 1 hour.
Posted Jul 22, 2026 - 07:58 CEST
This incident affected: Trackunit Manager, Trackunit Go, Trackunit On, Trackunit API, Streaming API, and Trackunit Verify.