Manager and Verify not available

Incident Report for Trackunit

Resolved

The 3rd party provider reports that the incident has now been resolved.
Posted Dec 03, 2025 - 20:15 CET

Monitoring

Our 3rd party provider has mitigated the issue and are now monitoring. We will monitor and await resolution on their end before resolving the incident.
Posted Dec 03, 2025 - 16:56 CET

Update

Users may experience slowness when logging in and when creating users and accounts.
Posted Dec 03, 2025 - 15:11 CET

Identified

Due to a disruption in 3rd party provider, we're experiencing issues.
Posted Dec 03, 2025 - 14:35 CET

Investigating

We are experiencing problems that cause Manager and Verify to be unavailable
Posted Dec 03, 2025 - 14:32 CET
This incident affected: Trackunit Manager and Trackunit Verify.