Trackunit support systems are unavailable

Incident Report for Trackunit

Resolved

This incident has been resolved.
Posted Jan 05, 2026 - 19:18 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 05, 2026 - 16:10 CET

Investigating

We are currently experiencing a issue with the Trackunit support center, which is currently unavailable.
Posted Jan 05, 2026 - 15:37 CET
This incident affected: Trackunit Support Services.