Trackunit Support Ticketing System not operational
Incident Report for Trackunit
Resolved
The Support ticketing systems are operating normally again but with longer than usual reply times due to a backlog buildup.
Posted Mar 05, 2024 - 17:01 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2024 - 14:36 CET
Identified
Currently our Support ticketing system and Help Center is not operational. Please reach out to us via phone for urgent matters.
Find our phone numbers at https://trackunit.com/about/contact/, or post on https://community.trackunit.com/ which we will monitor until the Support platform is operational again.
Posted Mar 05, 2024 - 14:13 CET