Potential unstability experienced in Verify

Incident Report for Trackunit

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 14:46 CET

Update

We are continuing to monitor for any further issues.
Posted Mar 18, 2026 - 14:22 CET

Monitoring

We have identified and resolved the issue. We will continue to monitor the situation.
Posted Mar 18, 2026 - 14:22 CET

Investigating

We are currently investigating an issue impacting general performance of Verify
Posted Mar 18, 2026 - 14:11 CET
This incident affected: Trackunit Verify.