Degraded Platform Performance

Incident Report for Trackunit

Resolved

This incident has been resolved.
Posted Jan 30, 2026 - 15:36 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 30, 2026 - 14:48 CET

Investigating

We are currently experiencing degraded performance across parts of the Trackunit platform. This may affect Manager, Verify, and some API endpoints.
Posted Jan 30, 2026 - 13:41 CET
This incident affected: Trackunit Manager, Trackunit Go, Trackunit On, and Trackunit API.