irisX Analytics Permissions Management Not Working

Incident Report for Trackunit

Resolved

Fix has been released
Posted Dec 11, 2025 - 14:56 CET

Update

We are continuing to work on a fix for this issue.
Posted Dec 11, 2025 - 13:38 CET

Identified

We have identified the issue and a fix is being implemented.
Posted Dec 11, 2025 - 13:37 CET

Investigating

Customers are not able to grand access to IrisX Analytics through the Trackunit Manager. Until this is fixed please contact support.
Posted Dec 11, 2025 - 13:36 CET
This incident affected: Trackunit Manager.