Parts of data shown in Manager is not updated
Incident Report for Trackunit
Resolved
Fix has been deployed and everything should be back to normal again
Posted Mar 25, 2024 - 19:21 CET
Update
Hotfix has been made and is being deployed ASAP.
Posted Mar 25, 2024 - 19:10 CET
Identified
We have identified the issue and is working on a fix
Posted Mar 25, 2024 - 18:24 CET
This incident affected: Trackunit Manager, Trackunit Go, and Trackunit API.