Degraded Platform Performance

Incident Report for Trackunit

Resolved

System performance is back to normal.
Posted Jan 27, 2026 - 16:26 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 27, 2026 - 15:48 CET

Investigating

We are currently experiencing degraded performance on the Trackunit platform.Some users may notice slower response times, primarily related to events and the attention list.Our team is investigating the issue and working to restore normal performance as quickly as possible.We will provide updates as more information becomes available.
Posted Jan 27, 2026 - 15:18 CET
This incident affected: Trackunit Manager, Trackunit Go, Trackunit On, and Trackunit API.