Asset metadata update delays

Incident Report for Trackunit

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 18:55 CEST

Investigating

Assets created or modified might not immediately show the changes. No data has been lost and changes will show up eventually.
Posted Aug 05, 2025 - 18:50 CEST
This incident affected: Trackunit Manager, Trackunit Go, and Trackunit On.